Knowledgebase : RPnow 4.0 > RPnow 4.0 FAQs
If you are trying to install/take RPnow exams via LTI exam link, Please refer to the links below: PDF : http://info.psionline.com/ltistudentguide (Copy the link to download the PDF) Video Walkthrough : https://youtu.be/7eYLFBMql2I [https://youtu.be/7e...
If you want to check the compatibility of your computer with PSI Secure Browser, below is a link and the requirements for running the Standalone System Check. SUPPORTED OPERATING SYSTEM WEBSITE SUPPORTED BROWSERS Windows: 7, 8, 10 http://syst...
NOTE: MAC OSX 10.15 - CATALINA, TABLETS, HYBRID DEVICES, AND MOBILE DEVICES ARE NOT SUPPORTED.   Remote Proctor Now System Requirements: RPNOW V4.X OPERATING SYSTEM REQUIRED PLUG-INS CONNECTION SPEED DATE AND TIME OTHER Windows 7, 8, 8.1, ...