RPNow - Browser does not meet the minimum requirements for Canvas
Posted by , Last modified by Abby Corre on 08 November 2020 12:13 PM

If you encounter an issue with Canvas prompting for an error message ," Browser does not meet the minimum requirements for Canvas " , Kindly disregard the error message and continue taking the exam.

 

If you continue to experience issues with RPNow. Kindly contact our Technical Support team . Click here.

 

Thanks

 

PSI Support


Comments (0)